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Vibration Monitoring and 
Predictive Maintenance 
Solutions Guide

A PDF version of this Solutions Guide is available at https://goo.gl/6S3RBD

Background
Industrial facilities have hundreds of critical rotating assets such as motors, pumps, 
gearboxes, and compressors. Unexpected failures result in costly down-time. 
An equipment health monitoring (EHM) preventative maintenance solution uses 
machine learning to identify when assets exceed pre-defined parameters. 

Value
• Increase Uptime—Eliminate unplanned shut-downs
• Reduce Maintenance Cost—Repair prior to failure or extensive collateral 

damage
• Effective Maintenance/Parts Scheduling—Spare parts and labor planning
• Ease of Use—Reduce installation costs and eliminate complexity of traditional 

data analysis
• Improve Asset Selection—Use data to assist in root cause and reliability analysis
• IIoT—Real-time alerts for better decision making and remote asset management

Banner Solution – Monitors 
vibration levels on rotating 
assets to detect:

• Imbalanced/Misaligned Condition
• Loose or Worn Components
• Improperly Driven or Mounted Components
• Over-temperature Condition
• Early bearing failure

How Banner Solves
• Banner’s Wireless vibration/temperature sensor continually monitors RMS velocity, high frequency acceleration, and temperature on 

rotating equipment, but uses vibration data only when asset is operational
• DXM Controller uses a machine learning algorithm to baseline values and set control limits for alerts with limited end-user interaction; 

creates a “Check Engine Light” for each motor
• DXM Controller collects data for trending and analysis; a script defines acute verses chronic issues
• Data and alerts can be sent to the host control or to the cloud for IIoT connectivity 

Sure Cross Vibration and 
Temperature Sensor

QM42VT1 and Q45U Wireless 
Node

Sure Cross DXM100 
Wireless Controller

PLC/PC
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Guide Features and Benefits
 CONTINUOUS VIBRATION MONITORING Monitor vibration data on up to 16 motors sensing X and Z axis RMS Velocity and high frequency 

RMS Acceleration. RMS Velocity is indicative of general rotating machine health (unbalance, 
misalignment, looseness) and high frequency RMS Acceleration is indicative of early bearing wear.

SELF-LEARNING BASELINE & THRESHOLDS Prevent users from having to generate baselines or alarms by using machine learning algorithms to 
create an initial baseline reading and warning/alarm thresholds for each motor individually.  

ACUTE & CHRONIC ALARMS “Check Engine Light” Alarms and Warnings are generated for both acute and chronic conditions 
for each motor. Acute thresholds indicate a short-term condition such as a motor jam or stall 
which cross the threshold rapidly. Chronic thresholds use a multi-hour moving average of the 
vibration signals to indicate a long-term condition such as a wearing/failing bearing or motor.

MOTOR RUN-TIME Recognize and differentiate running vs OFF state to track cumulative run-time for each motor.

TEMPERATURE ALARMS Each vibration sensor will also monitor Temperature and alarm when the threshold is exceeded.

REMOTE MASTER LIGHT Use a master tower light to indicate an OR’d status of all vibration alarms

SMS TEXT/EMAIL ALERTS Generate SMS text and/or email alerts based on individual warnings and/or alarms

CLOUD MONITORING Push data to Cloud Webserver or PLC (via LAN or Cellular connection) for remote viewing, 
alerting, and logging.

Solution Components
Model Description

QM42VT1 Sure Cross® Vibration and Temperature Sensor  

DX80N9Q45U or DX80N2Q45U Sure Cross® Wireless Q45 Sensor Node Universal 1-Wire Serial; select either 900 MHz or 2.4 
GHz ISM radio to match the DXM100  

DXM100-B1C1R1 or DXM100-B1C1R3 with firmware 
version 2.0

DXM100 Wireless Controller with Cell; select either 900 MHz or 2.4 GHz ISM radio to match the 
Q45Us; C1 only necessary if Cell Module is desired

The following mounting options are listed from least effective to most effective. In all mounting options, eliminate any sensor movement that 
could lead to inaccurate information or changes from the time-trended data.

Mounting Options Bracket Application Description

BWA-HW-057 
Thermal Conductive Adhesive Tape 
(Ships with sensor)

Single use flexible mounting option, but can introduce flex that 
reduces accuracy.

BWA-BK-001 
Flat magnet sensor bracket

Highly flexible and re-usable, flat magnetic mount for larger diameter 
surfaces or flat surface.

BWA-BK-008
Center mounting bracket with curved 
surface magnet attached to sensor 
bracket (includes BWK-BK-005)

Curved surface magnet mounts are best suited to smaller curved 
surfaces. Orient in the correct direction for the strongest mount. 
Offers flexibility for future sensor placement and provides sensor 
thermal isolation from surface temperature up to approximately 150 
°F (65 °C) .

BWA-BK-005
Center mounting bracket – accepts 
any #4 or M6 flathead screw (Ships 
with sensor)

Flat bracket permanently epoxied to motor and sensor screwed to 
bracket (very effective) or flat bracket with direct screw mount to 
motor and sensor (most effective). Ensures best sensor accuracy and 
frequency response. Recommend epoxy designed for accelerometer 
mounting: Loctite Depend 330 and 7388 activator
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The following guide demonstrates how to bind the wireless Q45U nodes to the DXM and load a preconfigured XML file and script for up to 16 
vibration monitors. The XML file only requires some minor modifications to be customized for any site.

Step 1: Bind the System and Assign Addresses
Binding each of the Q45U Nodes to the DXM100 establishes a secure connection between them and assigns a specific network address to 
each Q45U in the wireless network. 

1. For each VT1 and Q45U pair, connect the VT1 to the Q45U’s integral 5-pin connector. 
2. Apply power to the DXM. 
3. On the DXM: Use the arrow buttons to select the ISM Radio menu on the DXM’s LCD. Press Enter. 
4. Select the Binding submenu. Push Enter. 
5. On the Q45U: Starting with the Q45U for Motor #1, triple-click the button to begin the binding procedure. 

The green and red LEDs flash four times after the Node is bound. This Node is now bound to the Gateway in the DXM as Node ID 1. 
The amber light may turn on after binding, indicating the Q45U has entered into a faster sampling mode, and stops after 15 minutes. 

6. Label the device for future reference using the included label. 
7. On the DXM: If you are done binding the devices, press Back to return to the main 

menu. If not, continue to the next step. 
8. If you are binding another Q45U to the Gateway, change the DXM menu to Bind 

to > 2 and press Enter. Triple-click the Q45U button to begin binding. The Node 
binds to the Gateway in the DXM as Node ID 2. 

9. Continue repeat the previous step for as many VT1/Q45U pairs that you have. 
10. On the DXM: Press Back to return to the main menu. 

1
2
3

5
4

1 - Button 
2 - Red LED 
3 - Green LED 

4 - Not Used 
5 - DIP Switches

Step 2: Conduct a Site Survey
Conduct a Site Survey to verify the wireless connection between your Q45s and the DXM.

1. On the DXM: Use the arrow buttons to select the ISM Radio menu. Push Enter.
2. Select the Site Survey submenu, and press Enter.
3. Select each Node ID within the system to verify the wireless connection between the Node and the DXM.
4. When you are finished running the site survey, press Back twice to return to the main menu.

Forgetting to exit the site survey causes system issues and reduces the battery life of the Q45Us.
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Step 3: Install the Vibration Sensor
It is important to mount the vibration sensors on a motor correctly for the most accurate readings. There are some considerations when it 
comes to the installation of the sensor. 

The vibration sensors have an X and Z axis indication on the face of the sensor. The Z axis goes in a plane through the sensor while the X is 
horizontal.

• Install the line corresponding to the X axis in line with the shaft of the motor or axially. 
• Install the Z axis of the sensor to go into/through the motor. 

Install the sensor as close to the bearing of the motor as possible. Using a cover shroud or location far from the bearing may result in reduced 
accuracy or ability to detect certain vibration characteristics.

Step 4: Configure the System
To customize the system to an application, make some basic modifications to the template files. There are three files uploaded to the DXM: 
the XML file sets the DXM’s initial configuration, the SbFile1.dat Data file, and the ScriptBasic file reads vibration data, performs the machine 
learning, sets the thresholds for warnings and alarms, and organizes the information in logical and easy-to-find registers in the DXM.

Loading these files and making adjustments requires using Banner’s DXM Configuration Tool software and the Vibration Monitoring files 
available via in the links below.

1. After binding the Q45s pairs and running the Site Survey, install the Q45/VT1 pairs. 
Since the files automatically baseline after being loaded on the DXM, avoid creating installation vibrations by installing the sensors 
before uploading the files.

2. Download the preconfigured files. (https://goo.gl/F8cvZQ)
3. Extract the ZIP files into a folder on your computer. Note the location where the files were saved.
4. Connect the DXM, via the USB cable supplied with the DXM, to a computer containing the DXM Configuration Tool version 3 

software or download the software and install it on a computer. 
5. Launch the software.
6. Open the Vibration Monitoring XML file by going to the File > Open menu and choosing the configuration files.
7. Connect the software to the DXM by going to the Device > Connection Settings menu. Select Serial and then select the COM 

port that the USB cable is plugged into. Click Connect. If you are unsure which COM port to select, and multiple appear, attempt to 
connect to each one of them until you are successful.

8. Upload the Vibration Monitoring script file (.sb) by going to the Settings > Scripting screen. Click Upload file and select the script 
file.

9. Select the uploaded file in the window to the right of the Upload file button. 
10. Click Add Selected to Startup so that the DXM will run this script every time it restarts.
11. Upload the Vibration Monitoring data file (.dat) using the same Scripting screen. Click Upload file, change the dropdown to “All 

Files(*.*)”, and select the data file (.dat).
12. Save the XML file using the File > Save menu. Save the XML file any time the XML has been changed because the tool DOES NOT 

autosave.

https://www.bannerengineering.com/us/en/lp/vibration-monitoring-configuration.html
http://info.bannersalesforce.com/intradoc-cgi/nph-idc_cgi.exe?IdcService=GET_FILE&dDocName=b_4447978&RevisionSelectionMethod=Latest&Rendition=web
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Optional Steps: Customize the XML file
1. Within the DXM Tool, go to the Local Registers > Local Registers in Use screen.
2. Rename the Motors using the text boxes within the Register Name column. Because there are five registers per motor being 

monitored, copy and paste names for efficiency.
To display the motor vibration data, warnings and alarms on the website you must change the Web column drop-down lists to Read 
and Cloud Reporting to ON for each motor’ information piece (velocity, acceleration, alert mask, etc.) that you would like to appear 
on the website.

3. To display multiple Node’s motor vibration data on the website, change the cloud 
permissions.

a. On the Modify Multiple Registers screen, select Change in the drop-down list 
next to Cloud Permissions and Cloud Reporting.

b. In the drop-down list to the right, select ON for Cloud Reporting and Read for 
Cloud Permissions.

c. Set the Starting Register to 1 and the Ending Register to the value equal to 5 × 
Number of motors in the system (for example, set the ending register 80 for 16 
motors).

d. Click Change Registers on the bottom right of the section.
4. To display the baselines, warning thresholds, and alarm thresholds on the website, change 

the Cloud Permissions to Read and Cloud Reporting to ON. Follow step 3 except 
change the Starting Register to 501 and the Ending Register to 512 + 12 × (Number 
of vibration sensors in the system minus 1). Do not exceed an ending register 693 for 16 
Nodes.

5. Warnings and alarms within the system are contained within a single register for each of 
the up to 16 Nodes in local registers 101–116. The registers are labeled “NXX VibMask” 
where XX is the Node number. The number displayed is a decimal form of a 19-bit binary 
number with a value of 0 or 1 due to there being a potential of 19 warnings or alarms for 
each Node. 
The 19-bit binary masks are broken out as follows:

Bit Description Decimal Value

Bit0 Warning – X-Axis – Acute Velocity (0/1) × 2^1

Bit1 Warning – X-Axis – Acute Acceleration (Hi Freq) (0/1) × 2^2

Bit2 Warning – Z-Axis – Acute Velocity (0/1) × 2^3

Bit3 Warning – Z-Axis – Acute Acceleration (Hi Freq) (0/1) × 2^4

Bit4 Alarm – X-Axis – Acute Velocity (0/1) × 2^5

Bit5 Alarm – X-Axis – Acute Acceleration (Hi Freq) (0/1) × 2^6

Bit6 Alarm – Z-Axis – Acute Velocity (0/1) × 2^7

Bit7 Alarm – Z-Axis – Acute Acceleration (Hi Freq) (0/1) × 2^8

Bit8 Warning – X-Axis – Chronic Velocity (0/1) × 2^9

Bit9 Warning – X-Axis – Chronic Acceleration (Hi Freq) (0/1) × 2^10

Bit10 Warning – Z-Axis – Chronic Velocity (0/1) × 2^11

Bit11 Warning – Z-Axis – Chronic Acceleration (Hi Freq) (0/1) × 2^12

Bit12 Alarm – X-Axis – Chronic Velocity (0/1) × 2^13
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Bit13 Alarm – X-Axis – Chronic Acceleration (Hi Freq) (0/1) × 2^14

Bit14 Alarm – Z-Axis – Chronic Velocity (0/1) × 2^15

Bit15 Alarm – Z-Axis – Chronic Acceleration (Hi Freq) (0/1) × 2^16

Bit16 Warning Temperature ( > 158°F or 70°C ) (0/1) × 2^17

Bit17 Alarm Temperature ( > 176°F or 80°C ) (0/1) × 2^18

Bit18 RF Device Error (0/1) × 2^19
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The decimal version is the sum of the calculations shown in the right column for each Node’s mask register. Note that any value 
greater than zero in registers 101–116 indicates a warning or alarms for that particular Node. To know the exact warning or alarm, 
convert the decimal value back into a binary value, which is done on the Sensonix Web Services cloud site or can be done with a 
PLC or HMI. Multiple warnings and alarms may trigger on an event depending on severity.

6. Configure to Receive Email or Text Alerts based on an Action Rule. An easy example of an action rule to use is when the warning/
alarm masks in registers 101–116 are greater than zero, trigger to send an email or text immediately. There are six threshold rules 
set up, which trigger on Any Error, Any Acute Warning or Alarm, Any Chronic Warning or Alarm, or Any Radio Connection Error. To 
change the action rules:

a. Go to the Action Rules screen and expand any rule using the arrow next to the rule OR create a new action rule using the 
Add Threshold Rule button on the top.

b. Click on the arrow next to Email/SMS on State Transition.

c. Select the recipient of the SMS and/or email upon the action rule becoming true.

In the example shown, both SMS Recipient 1 and 2 and Email Recipient 1 and 2 receive a message when the action rule meets its 
criteria.
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Set up the Ethernet or Cellular Connection
By default, the XML file configures the DXM100 with an Ethernet Push interface with the ability to send emails and push the data registers to 
a webserver. The device can also be configured to use a cellular push if the DXM Controller contains a cellular module and data plan. This 
section is only necessary if the user wants to receive or display information beyond just the DXM Controller's LCD.

1. If the DXM will text, email, or push to the cloud webserver, set up the push interface.
a. On the DXM Configuration Tool, go to the Settings > Cloud Services screen.

b. Select the appropriate Push Interface (Ethernet or Cell) from the drop-down list.

Selecting Cell requires a cellular module be installed in the DXM Controller and a wireless plan be set up for sending data.
2. The Cloud Push Interval and Samples are set to 0 for this solutions guide because the script associated with this file establishes 

the push interval internally so it occurs immediately after the sample of the Nodes. 
3. Set up the email and text messages. SMS works only if the DXM has 

a cellular module. Expand the Email Recipients and SMS Recipients 
to enter up to 10 email addresses and 10 phone numbers, along with a 
custom message.

a. Go to the Settings > Mail and Messaging screen.

b. All SMTP fields should remain set to their default values, except 
the Password field. Enter “sxiemail1” into the password field.

c. Click Send SMTP Password.

d. Click Yes when asked to reboot the device.

Step 5: Save and Load the XML File to DXM
When changes are made to the XML file, save the changes. To apply the changes, load the XML file to the DXM.

1. Save the file by going to the File > Save menu.
2. Load the file onto the DXM by going to the Device > Send XML Configuration to DXM menu.

Because of the size of the XML file, the file may take up to three minutes to load. Verifying the file is loading by looking at the 
Application Status indicator in the status bar.

If the Application Status indicator is RED, close and restart the DXM Configuration Tool, unplug and re-plug in the USB cable and 
reconnect the DXM to the software. If the Application Status indicator is GREEN, the file upload is complete. If the Application Status 
indicator is YELLOW, the file transfer is in progress.



Banner Engineering Corp. • Minneapolis, MN U.S.A 
www.bannerengineering.com • Tel: 763.544.31648   P/N b_4449365 Rev. B

Vibration Monitoring and Predictive Maintenance Solutions Guide

Step 6: Push Information to the Cloud
The DXM100 can connect to the web via Ethernet or an internal cell module to push data from the site to the cloud and displayed on a 
website. To enable this capability for remote monitoring and alarms settings, modify the XML file.

The website for storing and monitoring the system's data is https://data.sensonix.net/.

1. Connect the DXM to a computer with the DXM Configuration Tool software.
2. Launch the software and connect to the DXM.
3. Load the saved XML file.
4. Go to the Settings > Cloud Services screen.
5. Visit the Sensonix Web Services website (https://data.sensonix.net/) and log into an existing account or register a new account.
6. Go to Settings > Sites, and click + New Site. Name your site.
7. On the Settings > Sites webpage, highlight and copy the Site ID.
8. On the DXM Configuration Tool: Return to the Settings > Cloud Services screen and paste the copied ID into the Site ID field.
9. Save the XML file (File > Save).
10. Upload the file to the DXM (Device > Send XML Configuration to DXM).
11. On the Sensonix Web Services website, click Send XML to Web and select the XML file that was just saved and uploaded to the 

DXM.
This creates continuity between the site created on the website with the DXM used in the field. The DXM pushes data to the website, 
which can be viewed at any time. Refer to the Sensonix Web Services Instruction Manual to review all the features available for 
monitoring, comparing data, and establishing warnings/alarms on the website.

Additional Features
Viewing Run Flags, Run Timers, and Run Counts
The Vibration monitoring guide also tracks when a motor is running, how long it has been running, and how many times it has turned on an 
off.  The following registers are used for each type of data:

• Motor Run Flag On/Off (0/1) – Local Registers 131–146
• Motor Run Timers (mins) – Local Registers 151–166
• Motor Run On/Off Counts – Local Registers 171–186

To view these on the web, change the cloud reporting and permissions using Optional Step #3.

https://data.sensonix.net/
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Adjusting the Velocity Thresholds for Run Flag
The script in this Vibration Solutions guide uses a function to automatically generate baselines and standard deviations by recognizing when 
a motor is running and collecting data. If a motor has a very low RMS velocity and acceleration when running, it can be very difficult to 
distinguish. To ensure the system is working properly, it is best to look at the Run Flag and X/Z RMS velocity over time. Visually it can be seen 
when a motor is running vs. off and if the Run Flag doesn’t turn ON (1) when the motor turns on, the Running Motor RMS Velocity threshold 
may need to be decreased. To assess this look at the data over time as shown below:

On the left, we can see that the motor Node 2 is between 150–425 for RMS velocity when running and below 100 when not running.  Looking 
at the Run Flag (green line) it only indicates “Running” at one point in time when the velocity has a spike. In comparison, if we look at the RMS 
velocities for Node 2 on the right, we can see the Run Flag (green line) clearly indicates when the motor is running and not running even if the 
velocities are fairly low. This means the acceleration is high enough to distinguish a “Running” state.

To adjust for this, we need to move the Running RMS Velocity Thresholds for the X and Z axis down to a level that is above the “OFF” 
state and below the lowest data collected in the “Running” state. In this case a value of 100 would be the appropriate value but it will vary 
depending on the motor and should be assessed for each individual situation. To change the Run Velocity thresholds:

1. Using the DXM Configuration tool, go to Local Registers -> Local Registers in Use
2. The X Velocity Run thresholds are in registers 301-316 and are labeled NX_RunThres_XV (where X is the motor ID number)
3. Change the value in the Constant or Timer column to an appropriate threshold for that motor as described above.
4. The Z Velocity Run thresholds are in registers 317-332 and are labeled NX_RunThres_ZV (where X is the motor ID number)
5. Change the value in the Constant or Timer column to an appropriate threshold for that motor as described above.
6. Once completed for each motor, follow Step 5: Save and Load XML File to DXM

After this velocity threshold adjustment has been made, re-baseline the motor. 

Re-Baselining a Motor
The script included with this guide uses the first few days’ worth of data points of a motor running after loading the script to the DXM to 
generate a baseline and statistics for determining warning and alarm threshold levels. If changes are made to the motor or vibration sensor, 
generate a new baseline. This ensures the system is running as accurately as possible. There are two ways to re-baselining a motor:

Baselining from the DXM
1. On the DXM: Use the arrows to select Registers. The registers are labeled NX_Baseline (where X is the motor node ID you want to 

baseline). 
2. Select the appropriate register to reset.
3. Click the Enter button.
4. Change the value to 1 then push Enter three times. The reset register automatically returns to zero after baselining.

Baselining from the Website
1. Go to the Dashboard > Sites screen.
2. Click Update Device for the site where the particular motor exists. 

The Update pop-up window appears.
3. From the Type drop-down list, select Register.
4. From the Register Name drop-down list, select the motor Node ID you want to baseline.
5. Enter 1 into the Value field and click Queue.
6. Repeat steps 4 and 5 for each motor Node to reset.
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Adjust the Temperature Warning and Alarm Thresholds
The default settings are 158 °F (70 °C) for a warning and 176 °F (80 °C) for an alarm. To change the temperature thresholds, follow these 
steps:

1. Using the DXM Configuration tool, go to the Local Registers > Local Registers in Use screen.
2. The temperature warning thresholds are in registers 365–380 and are labeled NX_TempW (where X is the motor ID number).  Change 

the value in the Constant or Timer column to your desired setting for that motor. 
3. The temperature alarm thresholds are in registers 381–396 and are labeled NX_TempA (where X is the motor ID number).  Change 

the value in the Constant or Timer column to your desired setting for that motor. 
4. After changing the settings for each motor, follow the steps in Step 5: Save and Load the XML File to DXM.

Local Registers
 Local Register # Description

Motor Processed Data

1 + 5 × (N − 1) Z-Axis Velocity

2 + 5 × (N − 1) Z-Axis High Freq. Acceleration

3 + 5 × (N − 1) X-Axis Velocity

4 + 5 × (N − 1) X-Axis High Freq. Acceleration

5 + 5 × (N − 1) Motor Temperature F

Sample Counter 90 1 second timer for script sampling

Read Rule Enable 91 Script Trigger register for read rules

Vibration Alert Mask 101–116 Warnings and Alert Mask

Warning/Alarm OR'd 117–130 Multiple variations of OR'd warning and alarms for thresholds

Motor Run Flag 131–146 Motor Run Flag

Motor Run Time 151–166 Motor running timers

Motor On Off Count 171–186 Motor Run On/Off Count

Motor Connection Status 191–206 Node Connection Status

Connection Status OR'd 207–208 Connection status registers for threshold rules

Baseline 211–226 Trigger New Motor Baseline (Read/Write)

Motor Run Thresholds 301–396 Initial Motor Run and Temperature Thresholds

Trended Data 401–464 Trended Vibration Data

Raw Motor Info 701–796 Raw Sensor data

Where N represents the Motor Node ID number.


